Integrating Cisco MDS 9124 switches with Nexus 5500s


I wanted to take a short minute and document the addition of a few Cisco MDS 9124s to our test lab at work. The purpose of the addition in the test lab is just to show the functioning and capabilities of the devices to work together. See my previous post on configuring native FC over a Nexus 5548 and 5596. The FC-specific portions of the MDS config are very similar to the Nexus line. Here’s what the middle state looks like. I haven’t taken the time to move the NetApp FC links to the MDS switches yet (or the UCS FC links instead), but the port provisioning process will be similar to those already documented in this post and the Nexus post. The Visio of what’s configured is below followed by my MDS configuration notes.


switchname NSC-MDS-1
int mgmt0
ip address 192.168.1.6 255.255.255.0
switchport speed 100
switchport duplex full
ip default-gateway 192.168.1.1
ssh key dsa force

line console
!set timeout in minutes to what client requires
exec-timeout 15 
exit

line vty
!set timeout in minutes to what client requires
exec-timeout 15 
exit

show port-license
show license usage

show module

vsan database
vsan 100
vsan 100 name FABRIC-A
vsan 1 suspend
exit

fcdomain distribute
fcdomain domain 20 static vsan 100
fcdomain commit vsan 100

zone mode enhanced vsan 100
no zone default-zone permit vsan 100

device-alias mode enhanced
device-alias commit

int port-channel 60
exit
int fc1/1 - 2
switchport rate-mode dedicated
channel-group 60 force
no shutdown
exit

interface port-channel 60
switchport mode E
switchport trunk mode on

vsan database
vsan 100 interface port-channel 60
exit

interface port-channel 60
switchport trunk allowed vsan 100
no shutdown

fcdomain restart vsan 100

Google

Advertisements


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s